martedì 7 gennaio 2014

Problemi con QGis in Debian

Al momento di usare QGis su Debian mi e' comparso il seguente messaggio


La cosa curiosa e' che avevo di recente usato QGis senza errori di sorta. Ho verificato che il malfunzionamento deriva dall'aggiornamento di alcune librerie di appoggio di QGis e del mancato aggiornamento di QGis stesso (il repository ufficiale non e' sincronizzato)
La soluzione e' quella di impiegare come repository direttamente qgis.org

per prima cosa si rimuove la versione di default di QGis

apt-get remove qgis python-qgis qgis-plugin-grass

si aggiunge al file /etc/apt/sources.list il repository di QGis
deb http://qgis.org/debian jessie main

si aggiungono le chiavi
gpg --recv-key 47765B75 gpg --export --armor 47765B75 | sudo apt-key add -
e si reinstalla QGis dalla nuova sorgente
sudo apt-get update sudo apt-get install qgis python-qgis qgis-plugin-grass
come risultato sono passato da una versione 1.7 non funzionante (o meglio con i plugin Python non funzionanti) ad una fiammante versione 2.0