martedì 15 gennaio 2013

IBM X40

Mi sono comprato usato un IBM X40 2371-67U...ed ho violato la legge che dice di non comprare mai computer usati ma riceverli solo come regalo.
La spesa di 150 euro e' ridicola ai 2200 euro necessari nel 2004 per comprare la macchina nuova ma purtroppo il portatile e' molto rovinato dato che

  • ha battuto almeno una volta con lo spigolo anteriore destro
  • connettendo l'alimentazione si sente un sinistro sibilo che scompare solo dopo aver aggeggiato sul connettore
  • l'hard disk ha diversi settori rotti ed emette qualche click (si consideri che questa macchina utilizza dei quasi introvabili dischi da 1.8 pollici per cui la riparazione e' piuttosto difficile)
  • lo schermo occasionalmente lampeggia
  • la tastiera non e' italiana
  • solo 512 Mb di Ram (mi e' stato venduto per un 1 Giga ma quando lo ho aperto e' risultato chiaro che non e' espandibile....256 Mb sono saldati alla scheda madre)
pero' cosa dire di
  • uno schermo da 12.1 pollici con risoluzione XGA (dimensione praticamente perfetta)
  • un peso di 1.2 Kg
  • uno chassis con materiali al magnesio per aumentare resistenza e diminuire il peso
  • una tastiera IBM e quindi fantastica
  • una porta Ethernet da Gb ed un ingresso per SD Card (quando e' uscito era il 2004 e tale dotazione era letteralmente fantascienza)
  • una durata della batteria di oltre 4 ore reali
  • disco da 40 gb (un lusso all'epoca)
  • Pentium M Centrino da 1.2 GHz (Cpu Family 6 Model 9 Stepping 5 1196 BogoMips)
Tra le curiosita' c'e' una porta speciale che assomiglia ad una USB per connettere un disco ottico esterno in formato proprietario




Ho provato in prima istanza ad installare una CrunchBang, tutto e' andato a buon fine e tutto l'hardware e' stato riconosciuto al volo. Purtroppo i repository di CrunchBang non sono granche' ed in fondo se voglio una Debian e' bene che installi una Debian e poi la personalizzi

Quindi sono passato ad un Debian Testing con XFCE e sono ovviamente iniziati i problemi
La scheda di rete wireless, una Intel 2000 Pro, non e' configurata in fase di installazione a causa di firmware proprietari per cui dopo aver installato il sistema di devono aggiungere i repository contrib non-free e poi si aggiorna il sistema come segue

apt-get update
apt-get install firmware-ipw2x00
modprobe ipw2100

Una volta installato stranamente si e' spenta la retroilluminazione (che puo' essere riattivata con il tasto FN e Home ed End)

Per finire fighissima la combinazione FN+PgUp che accende una lucetta che illumina la tastiera per la scrittura al buio